Checkster is currently experiencing an issue.

Incident Report for Outmatch, Inc

Resolved

This incident has been resolved.
Posted Mar 31, 2025 - 03:55 CDT

Investigating

Please be advised that the Checkster platform is currently experiencing an issue with one of the modules. We're working to resolve the problem as soon as we can. For updates on the outage, please visit https://status.outmatch.com.

We apologize for the inconvenience this may cause. If you have any further questions please contact us on support@outmatch.com.

Kind regards,
Outmatch
Posted Mar 31, 2025 - 03:42 CDT
This incident affected: Reference (Checkster) (Reference (US), Reference (EU), Reference (CA), Reference (AU)).